Boa tarde pessoal...

Eu sou novato em c#, desenvolvi um pequeno aplicativo de ordem de serviço para usar na empresa onde trabalho usando o visual studio 2015 e sql server express, terminei e gostaria de rodar esse aplicativo no notebook da empresa o problema que ao rodar ele da erro de conexão com sql server, eu ja instalei o sql server no notebook e tentei rodar o aplicativo de várias maneiras copiando da pasta debug, release, publicando e instalando mais o erro persiste, alguém pode me ajudar por favor ?

Exibições: 196

Respostas a este tópico

Posta a mensagem de erro e o stack trace, por favor. Isso ajuda a entender o problema.



Igor Tavares Barata disse:

Posta a mensagem de erro e o stack trace, por favor. Isso ajuda a entender o problema.

String connection

<connectionStrings>
<add name="Emprex.Properties.Settings.BDEmpreXSQLConnectionString" connectionString="Data Source=(LocalDB)\MSSQLLocalDB;AttachDbFilename=|DataDirectory|\BDEmpreXSQL.mdf;Initial Catalog=BDEmpreXSQL.mdf;Integrated Security=True" providerName="System.Data.SqlClient" />
</connectionStrings>
<startup>
<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5.2" />

Anexos

Se entendi o problema corretamente, a sua string de conexão deveria ficar +ou- assim:

<add name="Emprex.Properties.Settings.BDEmpreXSQLConnectionString" connectionString="data source=127.0.0.1;initial catalog=DATA_BASE_NAME;persist security info=True;user id=USERNAME;password=PASSWORD;MultipleActiveResultSets=true" providerName="System.Data.SqlClient" />

Altere alguns parâmetros, como: DATA_BASE_NAME, USERNAME e PASSWORD. Como vc disse que chegou a instalar o banco na máquina, deixei o endereço de loopback, mas se preferir, pode colocar outro IP ou o nome do servidor.

Espero ter ajudado, abs.

Uma coisa muito importante Danilo quando criamos uma aplicação, é verificar se o netframework da máquina está compatível com da aplicação. Quando iniciei a minha jornada de C#, que foi a pouco tempo, comecei a fazer no framework 4.5.1, porem como as máquinas aqui é tudo XP, tive que mudar para 4.0.

Uma dica ai!



Ricardo Henrique de Carvalho disse:

Uma coisa muito importante Danilo quando criamos uma aplicação, é verificar se o netframework da máquina está compatível com da aplicação. Quando iniciei a minha jornada de C#, que foi a pouco tempo, comecei a fazer no framework 4.5.1, porem como as máquinas aqui é tudo XP, tive que mudar para 4.0.

Uma dica ai!

Ricardo bom dia...

eu verifiquei isso sim o equipamento que eu quero rodar o software ja esta com windows 10 e o netframework atualizado, o programa abre normal, so que na tela de login eu busco o usu'ario e a senha no banco de dados ai começa o problema, pelo que entendi aqui o banco nao consegue ser anexado, da um erro de versao so que tando o banco que eu desenvolvi quando o banco do outro pc estao na mesma versao, tenho pouco tempo para programar pois nao e minha atividade principal por isso demoro um pouco para responder e esse primeiro programa que eu desenvolvo com sql server express 2012, estou meio perdido aqui...

Boa tardeDanilo.

Verifique as configurações do sql server.

tive um problema similar e apos trocar as configurações do sql server 

ficou resolvido

RSS

© 2017   Criado por Ramon Durães.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço